Ruby 1.9 going stable

I've just added arches to bug 411507, asking for stabilization of ruby 1.9.3p125 and its associated packages. This has been a long time coming but it looks like all the pieces are now in place for this.

Note that this currently only makes a difference for packages that request dev-lang/ruby directly. We don't have many of those, and most should already have been checked for ruby 1.9 compatibility. All other packages use the RUBY_TARGETS mechanism, so unless you have modified this yourself you won't get ruby 1.9 packages for now. If you want to install packages for ruby 1.9 then you can add ruby19 to the RUBY_TARGETS variable in /etc/make.conf.

For now the default for this variable is still "ruby18". We will add ruby19 in a couple of weeks when ruby 1.9 is actually stable and when possible issues have been fixed. Once ruby18 is no longer supported upstream we will also switch our default ruby implementation to ruby 1.9 but currently we don't have a set date for that.

Published on 19/05/2012 at 09h10 by Hans de Graaff, tags , , , ,

  • by Anton 24/05/2012 at 17h51

    I had some unstable ruby packages before and not sure if it cased the problem, but I've just synced and "emerge world" gave me the following: #required by virtual/rubygems-4, required by dev-ruby/rdoc-3.12[-test,ruby_targets_ruby19] >=dev-ruby/rubygems-1.8.24 ruby_targets_ruby19 #required by dev-ruby/racc-1.4.6-r1[-test,ruby_targets_ruby18] =dev-ruby/rake-0.8.7-r6 ruby_targets_ruby19 #required by dev-ruby/rdoc-3.12[ruby_targets_ruby19] =dev-ruby/racc-1.4.6-r1 ruby_targets_ruby19 #required by dev-lang/ruby-1.9.3_p125[rdoc] #required by dev-ruby/rdoc-3.12[ruby_targets_ruby19] =dev-ruby/json-1.5.4-r1 ruby_targets_ruby19 The problem disappears if I specify ruby19 in RUBY_TARGETS. I'll let it run for now and might file a bug report late. FYI ps. Sorry for the format.

comment Ruby 1.9 going stable

Trackbacks are disabled

Powered by Publify | Photo Startup stock photos