RUBY_TARGETS default now changed to include both ruby18 and ruby19

Contrary to my earlier post about ruby 1.9 going stable, we've decided to add ruby19 to the default RUBY_TARGETS now, rather than wait a few weeks. The main reason for this is that some packages correctly depend on dev-lang/ruby, and thus pull in ruby 1.9 now that it is stable, but they also pull in supporting packages that need to be installed for ruby 1.9. Without the ruby19 target portage will complain that it lacks the ruby_targets_ruby19 USE flag for these packages and it suggests to add them to package.use.

Technically this is correct, since RUBY_TARGETS=ruby19 will be expanded automatically to the ruby_targets_ruby19 USE flag, but it is not a very practical or user-friendly solution. This is why we have decided to add ruby19 to RUBY_TARGETS now, so that things will work out of the box. The ¨downside¨ of this is that more people will get ruby 1.9 pulled in now, and that packages will be installed by default for both ruby 1.8 and ruby 1.9. This was our intention anyway, since it will make switching to ruby 1.9 as the default ruby implementation easier down the line.

Our recommended setup is to not specify anything yourself, so if you already added the USE flags or modified RUBY_TARGETS yourself, we recommend that you remove these again since the default should now work correctly again. By using the defaults you'll make it easier to keep things working out of the box in the future. Obviously, if you care in some way, you can make all these changes!

Our Ruby project page has also been updated to reflect the current status of the different ruby implementations in Gentoo.

Published on 25/05/2012 at 21h13 by Hans de Graaff, tags , ,

Ruby 1.9 going stable

I've just added arches to bug 411507, asking for stabilization of ruby 1.9.3p125 and its associated packages. This has been a long time coming but it looks like all the pieces are now in place for this.

Note that this currently only makes a difference for packages that request dev-lang/ruby directly. We don't have many of those, and most should already have been checked for ruby 1.9 compatibility. All other packages use the RUBY_TARGETS mechanism, so unless you have modified this yourself you won't get ruby 1.9 packages for now. If you want to install packages for ruby 1.9 then you can add ruby19 to the RUBY_TARGETS variable in /etc/make.conf.

For now the default for this variable is still "ruby18". We will add ruby19 in a couple of weeks when ruby 1.9 is actually stable and when possible issues have been fixed. Once ruby18 is no longer supported upstream we will also switch our default ruby implementation to ruby 1.9 but currently we don't have a set date for that.

Published on 19/05/2012 at 09h10 by Hans de Graaff, tags , , , ,

Powered by Publify | Photo Startup stock photos