Moving innovations

Making people happy with innovative software

Ruby 1.9 unmasked

Today I finally closed bug 203706, 4 years after it was initially opened. That means that you can now go and install ruby 1.9.3 without having to unmask the packages and associated use flag. It also means that we'll try to add the ruby19 flag, when possible, to new ebuilds as we add them. With ruby 1.8 no longer in maintenance starting June 2012 we can now work towards making ruby 1.9 the primary stable ruby implementation. At this point in time, though, we don't officially support running your whole system on ruby 1.9 yet.

Unless you take action yourself nothing will change for the moment. If you want to start installing your ruby packages also for ruby 1.9, then you must add ruby19 to your RUBY_TARGETS in /etc/make.conf.

RUBY_TARGETS="ruby18 ruby19"

Note that this will only work in the testing tree for the moment. If you find bugs, please report them or drop by in #gentoo-ruby.

Today I finally closed bug 203706, 4 years after it was initially opened. That means that you can now go and install ruby 1.9.3 without having to unmask the packages and associated use flag. It also means that we'll try to add the ruby19 flag, when possible, to new ebuilds as we add them. With ruby 1.8 no longer in maintenance starting June 2012 we can now work towards making ruby 1.9 the primary stable ruby implementation. At this point in time, though, we don't officially support running your whole system on ruby 1.9 yet.

Unless you take action yourself nothing will change for the moment. If you want to start installing your ruby packages also for ruby 1.9, then you must add ruby19 to your RUBY_TARGETS in /etc/make.conf.

RUBY_TARGETS="ruby18 ruby19"

Note that this will only work in the testing tree for the moment. If you find bugs, please report them or drop by in #gentoo-ruby.

Published on 28/12/2011 at 14h40 by Hans de Graaff Tags

  • by Erik Moen 29/12/2011 at 16h26

    ^ this. A whole lot of stuff just depends on dev-lang/ruby. In my install this is dev-texlive/texlive-pictures-2011 and media-gfx/graphviz-2.26.3-r3. Thus, when >=ruby-1.9 is unmasked, the highest slot is pulled in by these packages. I have no idea about the differences between ruby versions, so I can't say how large the breakage from this will be. However, until something I want to use depends on ruby:1.9 it'll stay in my packages.mask.
  • by Nikos 28/12/2011 at 21h15

    "Unless you take action yourself nothing will change for the moment. If you want to start installing your ruby packages also for ruby 1.9, then you must add ruby19 to your RUBY_TARGETS in /etc/make.conf." That is not true. I don't have anything ruby-related in make.conf or package.use (I don't even know anything about ruby and why I need it). But a world update gives this: http://pastebin.com/raw.php?i=5aeWJ6hc

comment Ruby 1.9 unmasked

Trackbacks are disabled

Powered by Publify – Thème Frédéric de Villamil | Photo Glenn